ARCHICAD Calculation Guide
Introduction

The complex feature set of ARCHICAD’s Calculate function interacts with the project database to calculate the number of elements in a project, their spatial disposition and the quantity of element components. Specialized menu commands allow you to perform various calculations (quantity takeoffs, inventories, pricing, schedules). The extracted information can be searched using SQL, presented in customized layouts and exported easily to other applications.

The ARCHICAD Calculation Guide is a compact manual aimed at experienced users that explains the features used to generate reports about your project. The Calculation Guide Appendix presents two step-by-step calculation examples. (If you are new to the Calculation function, begin by reading a brief overview: “Calculation” in the Documentation chapter of the ARCHICAD Help.)
Contents

Calculation Commands ............................................................. 7
List Types .................................................................................. 10
Structure of the Calculation Databases ............................................ 14
Editing the Calculation Database .................................................. 19
  Editing Keys ............................................................................. 21
  Editing Units ............................................................................ 22
  Editing Components ................................................................. 24
  Editing Descriptors ................................................................. 26
Property Objects .......................................................................... 27
  Creating and Editing Property Objects ....................................... 28
  Defining Components and Descriptors ...................................... 30
  Linking Components and Descriptors to Databases .................... 33
  Linking Property Objects to Element Criteria ............................ 34
  Creating Criteria for Property Assignment .................................. 38
  Assigning Properties to Elements .............................................. 39
  Last Selection’s Properties ....................................................... 40
  Locating Property Objects ...................................................... 41
List Schemes and Templates ......................................................... 43
  The Setup List Schemes Dialog Box .......................................... 44
  Managing List Schemes ............................................................. 46
  Editing List Schemes .................................................................. 47
    Elements Tab Page ................................................................... 47
    Properties & Parameters Tab Page ............................................ 51
    List Format Tab Page ............................................................. 54
    Graphic Template .................................................................... 57
  Component Lists ........................................................................ 59
    Components Tab Page ............................................................. 59
    Properties & Parameters Tab Page ............................................ 59
  Zone Lists ................................................................................ 60
    Zones Tab Page ....................................................................... 60
    Properties & Parameters Tab Page ............................................ 61
    Related Elements Tab Page ..................................................... 61
Using the Format Wizard/Format Assistant .................................... 63
  Format Wizard: Layout Tab Page ............................................... 64
  Edit Page Item .......................................................................... 66
  Format Wizard: Content Tab Page .............................................. 69
Contents

Format Wizard: Fields Tab Page .................................................. 70
SQL in ARCHICAD ......................................................................... 72
Step By Step Examples .................................................................. 78
  A: Calculation Examples .............................................................. 78
  B: Graphic Template Setup Example ............................................ 83
Index .......................................................................................... 95
Calculation Commands

The Calculation function is a tool aimed primarily at advanced users. Many of the commands referenced in this section are not visible in ARCHICAD’s default work environment profiles. To add these commands to your work environment, use Options > Work Environment > Menus to add the following commands to an existing menu (e.g. Document > Schedules & Lists):

- Set up List Schemes
- Edit Database
- New Properties
- Edit Properties
- Last Selection’s Properties
- Link Properties to Criteria

Listing Commands

The Element Lists, Component Lists and Zone Lists commands generate lists of different formats and complexity for the entire project or a particular element selection based on the instructions defined in the Setup List Schemes dialog box.

To create the desired List, choose one of the predefined List Schemes from the submenus.

See the detailed explanation of the list types in List Types.
Selection and the Listing Commands

When you choose a listing command while elements are selected in the project, there may be a conflict between the listing command’s criteria and the selection. (For instance, if you choose a Window schedule when the current selection also contains Walls and Doors.)

In Options > Work Environment > Model Rebuild Options, the Selected Elements to be Calculated pop-up menu offers three options for managing this situation.

- If you choose the List All option, all the selected elements will be calculated in the list, even though they do not correspond to the filtering criteria.
- If you choose the Use Filters option, the filters defined for the list template will be applied to the selected elements; elements that do not correspond to these criteria will be ignored.
- If you choose the Show Alert option, a warning of conflict will appear. You will then be able to choose between the two options described above.

List Schemes and Output Reports

The sorting and analyzing of data, the calculation of required results and the formatting of reports are all done according to the selected List Scheme. List Schemes are predefined sets of instructions on how ARCHICAD should present the required results. List Scheme formats can be of two types:

- **Plain Text** reports display calculation results in editable tabulated text format. The reports appear in text windows and can be saved as spreadsheets, text files or HTML files.
- **Graphic** outputs allow for both alphanumeric and image information, including element symbol drawings, logos and other bitmaps. Graphic output reports can be saved as RTF List
files or ARCHICAD Project files. It is also possible to copy all or part of these lists into any of the Drawings.

Although the content of each language version is different, some factory default list schemes are available even if ARCHICAD is running without an active Library.

Graphic Schemes based on predefined templates can be configured using the **Format Assistant** or **Format Wizard**.

See *The Setup List Schemes Dialog Box and Using the Format Wizard/Format Assistant*. 
List Types

ARCHICAD can generate three types of calculation reports: Element Lists, Component Lists and Zone Lists.

**Note:** Add-On commands can also generate other list types.

Element Lists

Element Lists are best used for creating schedules and inventories, and to display the parameters of construction elements in a project.

<table>
<thead>
<tr>
<th>Element</th>
<th>Story</th>
<th>Layer Name</th>
<th>User ID</th>
<th>Library part</th>
<th>Width / Thickness</th>
<th>Height</th>
<th>Surface</th>
<th>Volumes</th>
</tr>
</thead>
<tbody>
<tr>
<td>WALL</td>
<td>0. Story</td>
<td>Exterior walls</td>
<td>WALL-013</td>
<td>0.26 m</td>
<td>2.44 m</td>
<td>18.07 m²</td>
<td>3.07 m³</td>
<td></td>
</tr>
<tr>
<td>WALL</td>
<td>0. Story</td>
<td>Exterior walls</td>
<td>WALL-014</td>
<td>0.26 m</td>
<td>2.44 m</td>
<td>8.01 m²</td>
<td>1.96 m³</td>
<td></td>
</tr>
<tr>
<td>WALL</td>
<td>0. Story</td>
<td>Exterior walls</td>
<td>WALL-015</td>
<td>0.26 m</td>
<td>2.44 m</td>
<td>16.68 m²</td>
<td>3.39 m³</td>
<td></td>
</tr>
<tr>
<td>WALL</td>
<td>0. Story</td>
<td>Exterior walls</td>
<td>WALL-016</td>
<td>0.26 m</td>
<td>2.44 m</td>
<td>18.37 m²</td>
<td>3.73 m³</td>
<td></td>
</tr>
<tr>
<td>WALL</td>
<td>0. Story</td>
<td>Exterior walls</td>
<td>WALL-017</td>
<td>0.26 m</td>
<td>2.44 m</td>
<td>11.34 m²</td>
<td>2.36 m³</td>
<td></td>
</tr>
<tr>
<td>WALL</td>
<td>0. Story</td>
<td>Exterior walls</td>
<td>WALL-018</td>
<td>0.26 m</td>
<td>2.44 m</td>
<td>12.21 m²</td>
<td>2.48 m³</td>
<td></td>
</tr>
<tr>
<td>WALL</td>
<td>0. Story</td>
<td>Exterior walls</td>
<td>WALL-019</td>
<td>0.26 m</td>
<td>2.44 m</td>
<td>1.94 m²</td>
<td>0.33 m³</td>
<td></td>
</tr>
<tr>
<td>WALL</td>
<td>0. Story</td>
<td>Exterior walls</td>
<td>WALL-020</td>
<td>0.26 m</td>
<td>2.44 m</td>
<td>10.29 m²</td>
<td>1.95 m³</td>
<td></td>
</tr>
<tr>
<td>WALL</td>
<td>0. Story</td>
<td>Exterior walls</td>
<td>WALL-021</td>
<td>0.26 m</td>
<td>2.44 m</td>
<td>5.37 m²</td>
<td>0.58 m³</td>
<td></td>
</tr>
<tr>
<td>WALL</td>
<td>0. Story</td>
<td>Exterior walls</td>
<td>WALL-022</td>
<td>0.26 m</td>
<td>2.44 m</td>
<td>8.96 m²</td>
<td>1.73 m³</td>
<td></td>
</tr>
</tbody>
</table>

**Note:** The total for all stories is 111.91 m² and 22.40 m³.
To generate Element Lists, ARCHICAD filters the project or the selection set for construction elements according to the configuration of the selected List Scheme. Elements matching the filter settings will be listed together with element Parameters, Components and Descriptors, if so defined in the List Scheme.

The following table lists different element types, their surfaces, and what Volume means for the different element types.

<table>
<thead>
<tr>
<th>Element</th>
<th>Surface</th>
<th>Surface</th>
<th>Surface</th>
<th>Surface</th>
<th>Surface</th>
<th>Volume</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wall</td>
<td>Ref¹</td>
<td>Other²</td>
<td>Edge²</td>
<td></td>
<td></td>
<td>Total volume</td>
</tr>
<tr>
<td>Column</td>
<td>Core</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Core</td>
</tr>
<tr>
<td>Beam</td>
<td>Top</td>
<td>Bottom</td>
<td>Left³</td>
<td>Right³</td>
<td>End</td>
<td>Total volume</td>
</tr>
<tr>
<td>Slab</td>
<td>Top</td>
<td>Bottom</td>
<td>Edge</td>
<td></td>
<td></td>
<td>Total volume</td>
</tr>
<tr>
<td>Roof</td>
<td>Top</td>
<td>Bottom</td>
<td>Edge</td>
<td></td>
<td></td>
<td>Total volume</td>
</tr>
</tbody>
</table>
List Types

<table>
<thead>
<tr>
<th>Element</th>
<th>Surface</th>
<th>Surface</th>
<th>Surface</th>
<th>Surface</th>
<th>Surface</th>
<th>Volume</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mesh</td>
<td>Top</td>
<td>Bottom</td>
<td>Edge</td>
<td></td>
<td></td>
<td>Total volume</td>
</tr>
<tr>
<td>Zone</td>
<td>Area</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Total volume</td>
</tr>
<tr>
<td>Object</td>
<td>Total</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Total volume</td>
</tr>
<tr>
<td>Door/Window</td>
<td>Surface of library part elements</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Total volume of library part elements</td>
</tr>
</tbody>
</table>

Notes:
1. including surfaces around openings with reveals and along reveal depth. “ref” stands for the reference line side of the wall and “other” for the side opposite the reference side of the wall.
2. all edges (top, bottom, both sides), including the edges of openings, except for some special edges of openings with reveals.
3. left and right side of the beam as defined by its orientation; left and right may be different when the beam is connected to a wall at a non-perpendicular angle.

Component Lists

Component Lists are generated when bills of materials, quantity takeoffs or price lists are required. These reports typically sum up and display component type properties; however, certain element parameters can also be listed.
### Zone Lists

Zone Lists are generally used to create room schedules and finish schedules. Zone Lists can include parameters of Zones and related construction elements. When related construction items are listed, the report is in fact an Element List where the range of calculated elements is limited by the Zones they belong to.

<table>
<thead>
<tr>
<th>Element Type</th>
<th>Fill Name / Composite Name</th>
<th>Description Short Text</th>
<th>Component Key Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>WALL</td>
<td>Common brick</td>
<td>-common brick masonry with 11.5 mm horizontal end</td>
<td>Memory</td>
</tr>
<tr>
<td>WALL</td>
<td>Common brick</td>
<td></td>
<td>Memory</td>
</tr>
<tr>
<td>WALL</td>
<td>Common brick</td>
<td></td>
<td>Memory</td>
</tr>
<tr>
<td>SLAB</td>
<td>Structural concrete</td>
<td>^ Reinforced concrete slab</td>
<td></td>
</tr>
<tr>
<td>SLAB</td>
<td>Structural concrete</td>
<td></td>
<td>Concrete</td>
</tr>
<tr>
<td>ROOF</td>
<td>Flat roof</td>
<td>^ Tiled roof and rafters</td>
<td></td>
</tr>
<tr>
<td>ROOF</td>
<td>Flat roof</td>
<td></td>
<td>Finishers</td>
</tr>
<tr>
<td>ROOF</td>
<td>Flat roof</td>
<td></td>
<td>Finishers</td>
</tr>
<tr>
<td>ROOF</td>
<td>Flat roof</td>
<td></td>
<td>Thermal &amp; moisture protection</td>
</tr>
<tr>
<td>ROOF</td>
<td>Flat roof</td>
<td></td>
<td>Wood-Plastic</td>
</tr>
<tr>
<td>ROOF</td>
<td>Flat roof</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

![List Types](image-url)
Structure of the Calculation Databases

Most of the information that is needed by ARCHICAD to create complex reports comes from Property Databases in active Libraries. You can use, extend, modify and update factory default Database(s) that come with ARCHICAD, and you can also set up multiple Databases that match your specific needs. Databases can include Components, Descriptors and Units organized in logical groups called Keys. Databases can be edited - including the creation of new Databases, Keys, Components and Descriptors - using the Calculation commands.

See also Calculation Commands.

Databases are sets of files placed in List Templates/Property Data folder of the ARCHICAD Library.

The built-in calculation database can be accessed through the Edit Database command.

Note: The database also contains the units that elements refer to. (See below.)

See also Editing the Calculation Database.

Keys

- Site work
- Contents
- Masonry
- Metals
- Wood Plasto
Data items in Databases are arranged in a hierarchical system categorized by Keys. A Key includes a group of Components and Descriptors that are logically grouped, typically following a country’s takeoff standards. Properties can, for instance, be grouped by type of structure, e.g., Walls, Columns, Roofs; by material, e.g., Concrete, Timber, Steel; or type of work, e.g., Foundation, Electrical, Furnishing. Cross-references are not possible, which means that the same Property item cannot be grouped in multiple Keys unless you duplicate it for each Key.

Every Key has a name and a code that are both alphanumeric definitions. A database’s Keys are arranged in alphabetical order by their codes. Keys can have a hierarchy among themselves which is also controlled by the code. The Code is the identifier whose name can be descriptive.

Example:

A Key named ‘Concrete’ is created. Its Code is ‘003’.

Another Key named ‘Precast Concrete’ is created. Its Code is ‘003.001’. Because of this format, it becomes the sub-key of the Key ‘Concrete’

An additional Key named ‘Precast Wall’ is created. Its Code is ‘003.001.001’. Because of this format, it becomes the sub-key of the sub-key ‘Precast Concrete’.

This way up to four levels of hierarchical Keys and sub-keys may be created.
Components

Components can either be the material ingredients (steel, concrete, etc.) of a structure, or anything (price, man hours, etc.) that can be measured in proportion to elements of the structure type. Each Component has a name, a code, a quantity definition, a unit and a reference to its proportion to related construction elements.

- **Code**: can be any alphanumeric string (e.g. ‘1143’, ‘Wall-012’, ‘JKG-ft’, ‘345fdsr’ etc.)
- **Name**: text string identifying the Component for the user (e.g. ‘gravel’)
- **Unit**: a numeral value (e.g ‘412.5’)
- **Quantity**: any of the Units defined under ‘Unit’ within the same Database (e.g. ‘kg’, ‘m2’, ‘Euro’, ‘$’ etc.) – selectable from pop-up menu.
- **Reference Quantity**: predefined set of values. The component will be calculated proportionally to the selected Reference Quantity.
  - **Item**: the component will be calculated per piece of the construction element
  - For other reference units, see the below table and its explanation:

<table>
<thead>
<tr>
<th>Referred element</th>
<th>Length</th>
<th>Surface A</th>
<th>Surface B</th>
<th>Surface C</th>
<th>Volume</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wall</td>
<td>(Ref+other)/2</td>
<td>Ref</td>
<td>Other</td>
<td>Ref+other</td>
<td>Total vol.</td>
</tr>
<tr>
<td>Column</td>
<td>Height</td>
<td>Around veneer</td>
<td>Around veneer</td>
<td>Around veneer</td>
<td>Core+veneer</td>
</tr>
<tr>
<td>Beam</td>
<td>(Left+right)/2</td>
<td>Left</td>
<td>Right</td>
<td>Total</td>
<td>Total vol.</td>
</tr>
<tr>
<td>Slab</td>
<td>Perimeter</td>
<td>Top</td>
<td>Bottom</td>
<td>Top+bottom</td>
<td>Total vol.</td>
</tr>
<tr>
<td>Roof</td>
<td>Perimeter</td>
<td>Top</td>
<td>Bottom</td>
<td>Top+bottom</td>
<td>Total vol.</td>
</tr>
<tr>
<td>Mesh</td>
<td>Perimeter</td>
<td>Top</td>
<td>Bottom</td>
<td>Total</td>
<td>Total vol.</td>
</tr>
<tr>
<td>Zone</td>
<td>Perimeter</td>
<td>Area</td>
<td>Area</td>
<td>Area</td>
<td>Total vol.</td>
</tr>
<tr>
<td>Object</td>
<td>Length along x axis (=A)</td>
<td>0</td>
<td>0</td>
<td>Total</td>
<td>Total vol.</td>
</tr>
<tr>
<td>Opening</td>
<td>Width of the opening</td>
<td>Width* height</td>
<td>Width* height</td>
<td>Surface of the elements in the library part</td>
<td>Total volume of the elements in the lib. part</td>
</tr>
</tbody>
</table>

- **Abbreviations**:
  - ref: this means the reference line side of a wall
  - other: this means the opposite side of a wall
left: this means the left side of a beam taking into account its orientation
right: this means the right side of a beam taking into account its orientation

• Meanings:
  components proportional with column length: Height of the column is taken instead of 0
  components proportional with beam length: (left+right)/2 is taken instead of 0
  components proportional with object length: the parameter A is taken instead of 0
  components proportional with column surfaces: the surface around the core is omitted, only
  the surface around the veneer is taken. If there is no veneer, the core surface is taken.

Notes:
• the left and the right side length of a beam may be different when it is connected to a wall in a
  non‐perpendicular angle.
• some values are intentionally different from the appropriate element list values, as the
  associated components are usually calculated based on different surfaces. For example you
  may want to calculate the painted surface of a wall. In this case you are not interested of the
  edge surface but the sum of the reference and the opposite side surface of the wall.
Components can reside in Databases (global) or locally in Property Objects. Library Part type
construction elements (Objects, Lamps, Windows and Doors) can also have locally defined
(i.e., object‐specific) Properties: however, these are only available for the Library Part they
were defined in, and cannot be linked to other elements. Property Objects can be created and
edited using the File > Libraries and Objects > Open Object, then editing in the Property Script
window, or by using the appropriate Calculation commands: New Properties and Edit
Properties.

For more information, see Property Objects.

Descriptors

Descriptors are text elements related to structure types, e.g., finishing, security, shipping,
assembly or handling information. Descriptors are simply displayed in reports: they are not used
in calculations and are not linked to components or element parameters. Each Descriptor has a
name (also called short text), a code and the full description (long text).
Just like Components, Descriptors can reside in Databases (global) or locally in Property Objects.
Structure of the Calculation Databases

Units

Every Database has a special item group for the Units used in calculations. The Units set is on the same hierarchy level as the primary Keys of the Database. An unlimited type of Units can be defined for every Database.
Editing the Calculation Database

Choose the Edit Database command. The resulting dialog box contains the controls to create, customize, modify and delete the elements of the database(s) ARCHICAD uses to process your project information for reports.

The information elements are arranged in hierarchical order. You can view the contents of a database in the left-hand side of the dialog box.

The right-hand side of the dialog box changes according to the item selected on the left (see specific sections for details).

At the bottom of the dialog box, use the “Details of Database items on the same level” section to view the details of all the items that are at the same level as the one selected on top, that is, all databases, all keys in a database, all components under the same key, etc.

The default ARCHICAD database contains numerous preset Keys, Components and Descriptors, as well as the Unit set, listed at the very bottom.

You can remove selected databases or database items with the Delete button at top, or create new databases or database items with the Create pop-up list at top right.

Important: When you leave this dialog box and click Yes in the Save Changes dialog box, ARCHICAD overwrites the corresponding database files with your changes.
Editing the Calculation Database

The database files can be saved to the List Templates subfolder of the ARCHICAD Library folder. When creating a new database, a set of new files is generated using the name of the new database.

In addition to the _KEY (keys), _COMP (components), _DESC (descriptors), _UNIT (units) and _CRIT (criteria assignment) files, a new _SCHEME (list scheme) and _MASTER_GDL files are also created.
Editing Keys

Highlight the name of a key in the database to edit its Code and Name in the text fields in the right-hand side of the dialog box.

The order and hierarchy of keys is defined using the codes: subordinate keys appear at lower levels, e.g., together with primary components and descriptors of a key. The key code can include any character, but when establishing a hierarchy, define keys as you would an IP address, in other words, a maximum of four sets of three digits separated by dots, e.g., “100.200.300.124”. Separator dots in the key code help define a hierarchy.

Keys must be unique within a database.

Example of fourth level sub-key
Editing Units

Highlight the name of a selected unit to edit its attributes using the controls in the right-hand side of the dialog box.

The top (uneditable) row displays the name of the database the selected unit belongs to. Edit the name of the unit in the text field provided.

The five formatting options in the center of the window control how the units will be displayed in the plain text list. Please bear in mind that Graphic Templates can override these settings.

1. Check the 'Justify Left' checkbox for the calculated value using the unit to be justified to the left, causing the remaining characters defined by 'Width' padded with SPACES. As default, all Units are right-justified and character places on the left are padded with SPACES.
2. Checking the 'Plus Sign' checkbox inserts a '+' sign as the first character of the values string, allowing one character less in the number value.
3. Checking the 'Space before positive values (if no Plus sign)' checkbox places a SPACE character as the first character, if no plus sign is specified to be placed, making it possible for all values to align well to the left.
4. Checking the 'Don't display Zero wholes' checkbox will not display the Zero whole and the decimal separator, in case the absolute of the displayed value is between 0 and 1 inch. This applies to values displayed in decimal format. Such can be the case with width and height of Windows and Doors, for example.
5. Check the 'Display Zero inches' checkbox for Zero to be displayed when the absolute of the displayed value is between 0 and 1. This applies to values displayed in Imperial format.
• In the **Width** text field, set the number of digits to be used when displaying the unit. Note that the Width value cannot be less than three.

• Choose the desired number of decimals places to be displayed in reports from the **Decimals** pop-up list in the bottom right corner.

• Use the **Conversion Unit** pop-up at the bottom of the dialog box if the selected database unit is different from the one chosen in the **Options > Project Preferences > Calculation Units & Rules** dialog box. Choose “none” from the pop-up list if using this option is not appropriate. Selecting the proper conversion units decreases calculation errors when database units and calculation units are different.

  **Note:** ARCHICAD calculations are performed according to the settings of the **Calculation Units and Rules** dialog box (**Options > Project Preferences > Calculation Units & Rules**) except when instructions in Graphic Templates override the settings.
Editing the Calculation Database

Editing Components

Click the plus sign next to any Key in the Database tree in the left-hand side of the Edit Database dialog box to see whether the selected Key has Components, Descriptors or both grouped in it, then click the plus sign next to the Components icon to view the items belonging to the selected Key.

To edit any of the Component records in the selected Database, highlight its name in the Database tree. The right-hand side of the dialog box will display the attributes of the highlighted component.

Component type database records are identified by their Key-codes and Codes which appear in the second and third rows of the component attributes in the right-hand side of the dialog box. The component’s Code can be edited by typing the new number into the corresponding text field.

Components can be moved from one key to another using click-and-drag. You can drop the moved item either into the Components folder of the new key location if the key is open, or simply drop it into the Key folder. In the latter case, the moved component will automatically be placed in the Components folder of the key.

Edit the component’s name directly in the Name text field, or by clicking on its name in the Database tree.

The bottom three rows of the component’s attribute controls allow you to define:
• the Component **Quantity**
• the **Unit** used to calculate the component
• the number of component units per **Reference Quantity** unit, e.g., eight pieces of tiles per square meter of a wall’s inside surface.

*For more information on Reference Quantity, see Components.*
Editing Descriptors

Descriptors are listed in the Database tree in the Edit Database dialog box. Select any Descriptor to edit it.

Descriptors can be moved from one key to another using drag-and-drop in the Database tree. The descriptor’s full text can be edited directly in the Full Text field.
Property Objects

What are Property Objects?

Property Object files are special ARCHICAD Library Parts without a 3D Script. Property Objects are generally used to describe specific structures for the purposes of calculation, e.g., the quantities and the detailed description of reinforced concrete beams used in the project.

*See the Component and Descriptor definitions above.*

**Hint:** Think of a Property Object as a custom cooking recipe including ingredients from your garden (local components), “in-house” cooking instructions (local descriptors), ingredients that need to be shopped for (database components) and instructions you commonly find in cookbooks (database descriptors). Just as the amount of ingredients must be adjusted to the number of people you cook for, in calculating the actual amount of components of an element, ARCHICAD calculates on the basis of the given relationship between each component and the reference parameter of the element calculated.

Data not directly derived from construction elements is contained or collected from databases through indirect links facilitated by Property Objects.

Properties are used to define quantities and descriptions of construction elements. The two types of Property definitions are Components and Descriptors. Components and Descriptors (along with Units) can reside in Databases or be defined locally. Local Properties definition is possible in any Library Part type element (Window, Door, Object, Lamp etc.) for the exclusive use of the Library Part, or in Property Objects. As well as local Properties, Property Objects can also access Database Properties, which are then assigned to construction elements.

Property Objects can be linked to elements either globally by matching certain criteria, or individually from the Settings dialog boxes of the different elements.

Topics in this section:

- Creating and Editing Property Objects
- Defining Components and Descriptors
- Linking Components and Descriptors to Databases
- Linking Property Objects to Element Criteria
- Creating Criteria for Property Assignment
- Assigning Properties to Elements
- Last Selection’s Properties
- Locating Property Objects
Creating and Editing Property Objects

The **New Properties** command opens a new, empty Property Object file that you are able to edit using the dialog box controls and ARCHICAD’s GDL language. The effect of choosing this command is identical with that of the **File > Libraries and Objects > New Object** command.

Choose the **Edit Properties** command to select an existing Property Object and edit it in its library part master window. (You can also edit Property Objects by choosing **File > Libraries and Objects > Open Object** and selecting the Properties File type.)
**Note**: If you choose this command while any construction element is selected in the ARCHICAD Project, all directly assigned Property Objects will open automatically. The Property Object type Library Part does not have a 3D Script or a 3D View. Otherwise, the available controls are similar to those of the other Library Part types, which are described in the ARCHICAD Reference Guide.

*For more information, see the “GDL Master Window” chapter in ARCHICAD Help.*
Defining Components and Descriptors

When defining Properties, you should first decide whether they will ever be assigned to different elements, whether they may ever be parts of different Properties combinations in Property Objects, or if only one Library Part will use them.

- A unique object’s properties, e.g., the coating of a custom-made truss, is best defined locally, within the Library Part.
- More generic Properties, e.g., the amount of cement needed to build elements made of reinforced concrete, are better described locally in Property Objects so that any such element can refer to them.
- The most generic Properties, e.g., the amount of paint needed for walls (Component) or general safety instructions (Descriptor), which are expected to be used in several Properties combinations are best defined as Database Properties so that any Property Object can refer to them.

Click the Components button in the left-hand side of the Library Part master window. This will display the Components controls on top of the window.

Click the New button to create a new Component line.
Type the desired values or strings into the Code, Name and Quantity text fields to define the corresponding attributes of the new component.
Use the Proportional With pop-up list to choose a reference quantity (Item, Length, Surface, Volume) for the component.
The following table shows the components referencing different parameters of ARCHICAD element types:

<table>
<thead>
<tr>
<th>Ref.element</th>
<th>Length</th>
<th>Surface A</th>
<th>Surface B</th>
<th>Surface C</th>
<th>Volume</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wall</td>
<td>(Ref+other)/2 (1)</td>
<td>Ref(1)</td>
<td>Other (1)</td>
<td>Ref+other</td>
<td>Total volume</td>
</tr>
<tr>
<td>Column</td>
<td>Height</td>
<td>Around veneer</td>
<td>Around veneer</td>
<td>Around veneer</td>
<td>Core+veneer</td>
</tr>
<tr>
<td>Beam</td>
<td>(Left+right)/2</td>
<td>Left (2)</td>
<td>Right (2)</td>
<td>Total</td>
<td>Total volume</td>
</tr>
<tr>
<td>Slab</td>
<td>Perimeter</td>
<td>Top</td>
<td>Bottom</td>
<td>Top+bottom</td>
<td>Total volume</td>
</tr>
<tr>
<td>Roof</td>
<td>Perimeter</td>
<td>Top</td>
<td>Bottom</td>
<td>Top+bottom</td>
<td>Total volume</td>
</tr>
<tr>
<td>Mesh</td>
<td>Perimeter</td>
<td>Top</td>
<td>Bottom</td>
<td>Total</td>
<td>Total volume</td>
</tr>
<tr>
<td>Zone</td>
<td>Perimeter</td>
<td>Area</td>
<td>Area</td>
<td>Area</td>
<td>Total volume</td>
</tr>
<tr>
<td>Object</td>
<td>Along X axis (A)</td>
<td>0</td>
<td>0</td>
<td>Total</td>
<td>Total volume</td>
</tr>
<tr>
<td>Door/Window</td>
<td>Width of opening</td>
<td>Width x height</td>
<td>Width x height</td>
<td>Surface of library part elements</td>
<td>Total volume of lib. part elements</td>
</tr>
</tbody>
</table>

Notes:

1. Including surfaces around openings with reveals and along reveal depth. “ref” stands for the reference line side of the wall and “other” for the side opposite the reference side of the wall.

2. Left and right side of the beam as defined by its orientation; left and right may be different when the beam is connected to a wall at a non-perpendicular angle.

Some values are intentionally different from appropriate element list values, as the associated components are usually calculated based on different surfaces. For example, you may want to calculate the painted surface of a wall: in this case, you are not interested in the edge surface but in the sum of the reference and opposite side surfaces of the wall.

To define a special reference, choose Custom from the Proportional with pop-up list. This will make active the field that the ‘Proportional with’ header points to, on top of the headers. Enter any GDL expression using global and local variables.

You define Descriptors in much the same way. Click the Descriptors button to display the appropriate controls on top of the window.
Click the **New** button to create a new Descriptor line.
Type the desired value in the **Code** text field and the appropriate **Short Text** (first line) in the corresponding text field.

Click the **Text** button to open the **Descriptor Full Text** dialog box where you can give a longer description of the part, element or structure. This description may include technical parameters and specifications or other useful assembling or safety instructions.
Linking Components and Descriptors to Databases

If you want a Component or Descriptor defined in a Property Object to be identified with a Database item, select it in the list of the Property Object’s master window, and click the Link to Database Item button at the top of the dialog box.

The Select Components or Select Descriptors dialog box appears. You can choose from all the relevant items in the selected database.

As long as a Component or a Descriptor of a Property Object is linked to a Database, the item will be updated with every update of the Database.

When a selected Component or a Descriptor is already linked to a database item, the name of the linking button changes to Remove Link to Database, and the Change Link button also becomes active. You can then either break the link to a database item, or replace it with a different one.

Object-specific items are listed in plain text, database items are listed in italic and the names of missing database items are grayed.
Linking Property Objects to Element Criteria

To define a combination of element parameters (type, pen color, size, material etc.) by which a Property Object is assigned to construction elements, choose the **Link Properties to Criteria** command.

A dialog box appears, displaying the links of the default set.

Links between construction elements (on the left) and Property Objects (on the right) are based on a set of criteria, including element type and different common or tool-specific attributes. Click **Edit Criteria** to open the **Criteria Selector** dialog box (see description below).

The Link Properties dialog box displays four parameters at a time. To see all available parameters, use the horizontal scrollbar at the bottom of the Criterion List.

Click any column header to sort the list alphabetically.

To link Property Objects to criteria or change the previously assigned Property Object, click **Link Property Object** in the upper right of the dialog box while the criterion is highlighted in the list. This opens the **Link Properties to Criteria > Link Properties** dialog box.
The **Choose Manually** tab page lists available Property Objects in the active libraries in alphabetical order. The currently assigned Property Object is highlighted in the list. To see the components and descriptors of highlighted Property Objects, open the Property Preview section of the dialog window.

Highlight the Property Object you wish to assign to the selected criterion.

If you need help to find Property Objects in the active libraries, click on the **Search by Keywords** tab. Type the keywords in the appropriate text field and press **Search** to list the Property Objects that match the keywords.

- **Click Link** button to confirm your selection.
**Property Objects**

- Click **Edit** to open the highlighted Property Object
- Click **New** to create a new Property Object.

In the **Link Property Objects to Criteria** dialog box, the two radio buttons give you a choice for how to interpret multiple criteria whose parameters partly coincide.

**Enable Property Objects of all links** means that both the Property Object assigned to a simpler criterion and the one assigned to a more specific criterion will be applied to matching elements.

An example:

The simpler criterion includes only two parameters, wall *Type* and solid brick *Fill*, and the assigned Property Object is one whose components are bricks and mortar.

The more specific criterion includes three parameters of which two, wall *Type* and solid brick *Fill*, are identical with those of the simpler criterion. The third parameter is whitewash *Material*, and the assigned Property Object’s only component is plaster. In this case, the construction elements matching the more specific criterion will receive not only the plaster component but also the bricks and the mortar. Elements matching the simpler criterion only (non-plastered walls) will receive the bricks and the mortar but not the plaster.

If you choose **Use more specific Criteria only**, a match to a more specific criterion always overrides a match to a simpler one. Elements matching a certain criterion will only receive the Property Object linked to that particular parameter combination. In the above example, the elements matching the criterion with three parameters would receive the plaster component only.

Only one criterion can be selected and edited at a time.

Click **Edit Criteria** to open the **Criteria Selector** dialog box.

Choose the Element Type for the active criterion from Find Elements pop-up, and click More Choices as needed to select and define additional criteria.

Save, load and rename or delete criteria sets using the commands from the pop-up list at the top right of the **Criteria Selector** dialog box. The list items activate the corresponding dialog boxes where you can perform the desired action.
The **Copy Settings** button is only active if a construction element is selected in the project. Click this button to set the parameter values to match those of the selected element.

![Criteria Selector](image)

**Note:** This action will also set the element type.

Click **Apply** to update the Criteria list.
Creating Criteria for Property Assignment

In order to create calculation reports that use the Properties information, Properties data must be linked to construction elements. Properties can be associated with construction elements through **Criteria** or **individually**. Assignment through **Criteria** is defined with the **Link Properties to Criteria** command.

Each Property Object can be associated to a unique combination of element selection criteria, e.g., the Property Object called “Concrete Wall” can be associated with all walls of concrete block fill, drawn in pen No.12, and placed on the “Exterior Walls” layer. When this option is active, ARCHICAD filters the project’s construction elements and automatically links the Property Object in question to all elements matching the given Criteria. Criteria sets are saved within the active Library so that they can be used in multiple projects.

**Note:** You can check this assignment by selecting an element, opening its settings dialog box and clicking the Listing Panel.

**Note:** The Listing Panel is not visible by default. To enable it in any construction element’s settings, go to Options > Work Environment > Tool Settings Dialog Boxes.

You can also choose to assign Property data directly, **individually** for each element in the Listing Panel of its Settings dialog box or in the Info Box.

**Note:** The Listing Panel is not visible by default. To enable it in any construction element’s settings, go to Options > Work Environment > Tool Settings Dialog Boxes.

A combination of Criteria-based linking and direct Assignment is also possible. 
*See also Creating and Editing Property Objects.*
Assigning Properties to Elements

When editing a construction element in its Settings dialog box, you can assign Property Objects to the element in the Listing panel.

**Note:** This panel is not visible by default. To enable it in any construction element’s settings, go to Options > Work Environment > Tool Settings Dialog Boxes.

The link can be made by criteria or individually.

To assign a Property Object through criteria (that is, all elements that match the criteria selection made in the Link Property Objects to Criteria dialog box - see above), check the Link Property Objects By Criteria box in the Listing panel. Property Objects that match these criteria will be shown in the panel.

You may wish to override this setting by creating a specific assignment for a particular element. In this case, uncheck the Link Property Objects By Criteria box, check the Individually box below and click Choose.

**Note:** It is possible to keep both checkboxes active at the same time and thereby create a combined assignment.

Assigning the Property Object manually or through keywords is done the same way as for criteria, as described earlier in this chapter.
Last Selection’s Properties

Selected Property Objects cannot be edited directly from the Settings dialog box. Use the Last Selection’s Properties command to access Property Objects from construction elements to which they have been assigned.

If any construction element is selected in the project, use Last Selection’s Properties to see which Property Objects are linked to the selected element.

Select a property object and view its details in the Contents section of the dialog box.

Click the Edit button to the selected Property Object to modify it directly in the Library Part Editor, if the selected Property Object item is object-specific. If the selected item belongs to a database, click Change Link in the upper right of the window to modify the item.
Locating Property Objects

You may need to locate a Property Object that contains a specific component or descriptor, or one which includes links to a specific database or a specific key. These two commands help you find what you need:

- Find Property Objects by Properties
- Find Property Objects by Elements

Use these commands to search based on a set of criteria.

**Find Property Objects by Properties**

Enter criteria and search terms as needed, then click **Find Property Objects**.

Highlight a Property Object name and click **Edit** to open the **Edit Properties** dialog box.

Let’s say you want to find all Property Objects within your ARCHICAD Database that has the text 'tile' in its Component Name. You would select the below two criteria.
Find Property Objects by Elements

You have all Walls selected on the Floor Plan. You want to find only those Walls that have studs in them. Enter the criterion shown above, then click the 'cross-section' button (cross-section of Selection and Criteria). As a result, only those walls are now selected whose associated Property Objects contain Components with 'stud' in their Name.
List Schemes and Templates

List Schemes are factory default or user-defined instruction sets to control how the Listing Engine processes and displays project information. List Schemes can be independent files or can reside in Databases.

List Schemes are of Element, Component and Zone types. It is also possible to create complete List Scheme files that contain definitions for Element, Component and Zone lists.

List Schemes can be configured to suit a large variety of needs, and new schemes can be created in the Set up List Schemes dialog box, accessed with the Set up List Schemes command. Moreover, graphic outputs are highly customizable using a Format Wizard (Windows) or Format Assistant (Mac).

See Using the Format Wizard/Format Assistant.

Templates

Graphic List Schemes are based on templates that contain information about the list’s structure, layout and content.

Templates can be of two types:

- Template files are simple text files residing in the active library. They are factory-shipped or created manually. It is also possible to create copies of embedded templates by saving them as external files.

- Embedded templates, created with the Format Wizard, reside in the list scheme itself. You can transform them into template files by unchecking the Include in List Scheme box on the Setup List Schemes dialog box’s List Format tab page (see later).

Note:

- Templates are coded in a simple programming language. It is highly recommended not to edit these files unless you are thoroughly familiar with the syntax.

- Template files cannot be edited with the Format Wizard.

Records and Fields

Graphic Templates define layouts to display and print information units called Records. Records are small layouts that can include numerous Fields and one bitmap image. Fields are units of alphanumeric data. Field contents are collected, filtered and calculated by the ARCHICAD Listing Engine. The bitmaps can be external image files from any of the active Libraries, ARCHICAD object symbols, 3D drawings generated by Property Objects and by the objects themselves, or Preview Pictures of ARCHICAD Library Parts in the active Libraries.

See Graphic Template and Using the Format Wizard/Format Assistant.
The Setup List Schemes Dialog Box

The Setup List Schemes command takes you to a complex dialog box where you can define which element types, components or zones will be calculated by ARCHICAD to produce the required report, as well as the complexity and format of the output.

Choose the Setup List Schemes command to open the corresponding dialog box. The Database tree (at the left-hand side of the dialog box) contains the available Databases, marked with the filing cabinet ( 文件箱) icon, and the List Schemes in the List Scheme folders. This list includes all the list schemes that are in databases placed in active Libraries.

**Note:** List Schemes will function in Teamwork projects only if you save them to the project’s Embedded Library.

List schemes are arranged in a hierarchy, organized by type in three folders: the Element, the Component and the Zone List Schemes. Each folder includes at least some default sets, even if no Library is loaded, including a Basic list.
User defined Schemes appear in the same hierarchy under the default Schemes. Plain Text Schemes are marked with spreadsheet-like icons.

- Schemes belonging to a database can only create lists from their own databases.
- Schemes that are independent from any database can be used for listing all loaded databases.

Select a List Scheme from the tree to see its configuration on the right.
Managing List Schemes

Click Create to create a new List Scheme, or select an existing one and click Duplicate.

**Note:** List Schemes will function in Teamwork projects only if you save them to the project’s Embedded Library.

Rename the new untitled Scheme or any other List Scheme by selecting its name and retyping it. Click the padlock toggle to lock or unlock a List Scheme for editing.

To remove List Schemes, select the name, and click the Delete button.

**Important:** Clicking OK in the Setup List Schemes dialog box will overwrite all changed List Schemes that are stored in the Preferences file of the Project and in the LISTSET.TXT database file placed in the Library.

- When starting ARCHICAD without opening a project file, List Schemes are loaded from the Preferences files (Listset files/*.lis/ will not be loaded from any of the loaded libraries);
- When opening a Project file, List Schemes stored in the project will be loaded. (Listset files/*.lis/ will not be loaded from any of the project’s libraries).
- When choosing File > Libraries and Objects > Library Manager, all List Schemes (*.lis) found in any of the selected libraries will be loaded.

**Note:** List Schemes will function in Teamwork projects only if you save them to the project’s Embedded Library.
Editing List Schemes

You can edit, modify and customize unlocked list schemes by selecting from the Available List Schemes area on the left.

Depending on the List Scheme type selected, the right-hand side of the dialog box will display three or four tab pages.

• When selecting **Element** or **Component** List Schemes, three pages appear: the Elements page, the Properties & Parameters page, and the List Format page.
• If the selected List Scheme is a **Zone** List, you can see four tab pages: Zones, Properties & Parameters, Related Elements, and List Format. Click the tabs to switch between pages.

Elements Tab Page

This is the first tab page. Use the controls (filters) in this page to select the construction elements to be calculated.

Filter by Element Type

Use the filter buttons with the familiar tool icons to determine which element types to list and which to exclude from report calculations. Click the **All** checkbox to select all construction element types.

**Note:** Unchecking the **All** checkbox will activate the custom setting last used.
List Schemes and Templates

Filter by Label and ID

Use these checkboxes to further filter the Element List for any element without an associative label and/or elements that have no associated ID.

Reduce Wall Quantities Based On Opening Size

The Reduce Wall Quantities option allows you to set the minimum size of wall opening that will be taken into consideration by ARCHICAD in wall surface and volume calculations. Type the size limit in the text field in accordance with local building code or project requirements.

Filter by Layer

Elements on unchecked layers will not be calculated. The pop-up menu allows you to list elements on All layers, Visible layers or Selected layers.
Filter by Story

The Stories scrolling list allows you to include elements placed on selected stories in calculations. Elements on unchecked stories will not be calculated. Click the All boxes to select all stories.

Filter by Property Objects

Use the Linked Property Objects pop-up list to determine whether you want to select particular Property Objects to further elaborate listing criteria.
- Choose All if you do not want to use this filter.
- Choose Elements Linked to Selected Property Objects if you wish to calculate elements to which certain Property Objects are assigned either by criteria or in the element’s own Settings dialog box.
• To make the Property Object selection, e.g., for listing construction elements made of reinforced concrete only, choose Select Property Objects in the pop-up list to open the corresponding dialog box.

The checkboxes next to folder names have three states: checked, unchecked, or minus. If the checkbox is checked or unchecked, all items in the folder in question will be used or ignored when filtering the project. If only some items are checked, a minus sign will appear.

View the components and the descriptors of the Property Objects at the bottom of the dialog box.

**Filter Listed Fills and Objects by Viewpoint**

The List Fills and Objects pop-up menu allows you to list Fills and Objects that are included in particular project viewpoints.

Once you choose a viewpoint type, a subdialog appears allowing you to choose any particular viewpoints of that type (e.g. certain Elevations) to include in this filter. (To include all viewpoints of the chosen type, check the “All” box in the subdialog box.)
To include several types of viewpoints, choose the “Any Selected Viewpoints” option, then go through the subdialog and check any viewpoints, of any type, to include in this filter.

Properties & Parameters Tab Page

The second tab opens the Properties & Parameters page. Use the controls in this page to determine the amount of information included for each element in the report.

Select Keys

Keys are logical categories in Databases, which group the primary Database items - Components and Descriptors - by type.

Select the desired Keys for filtering the components and descriptors to be listed. You can only select Keys from the Database in which the selected List Scheme resides. In the case of a database-independent scheme, you can select Keys from any of the existing databases.
Select Components and Descriptors

Use the Components and Descriptors pop-up lists to determine the combination of components and descriptors to be listed.

- Choose All to include all related Components (or Descriptors) in the calculation.
- Choose None to ignore Components (or Descriptors).

Select one of four global options:
- From Databases Only will include all properties (Components or Descriptors) residing in databases.
- Object Specific Items Only will include only locally defined properties (those in regular library parts or Property Objects).
- Custom Set From Databases Only opens the Select Descriptors and the Select Components dialog boxes, where you can define the set of properties to filter the report.
- Custom Set & Object Specific Items is a combination of the second and third options.
- If you want to use a filter set that does not match any of the predefined options, use the Customize button.

Example:

Let us say you have a Wall with a Property Object assigned to it, in which the following Components are created:
The first two are taken from the Database by clicking the 'Link to Database Item...' button in the top row and selecting an item from the Database for each. The other three Components are Local Components of the Property Object, meaning they will not become part of the Database so they are accessible for only those Elements and Objects to which this specific Property Object is assigned. Depending on how you filter components in Setup List Schemes, the resulting element list will vary:

- **All**: All five components are listed.
- **None**: Nothing is listed.
- **From Database Only**: Only the first two components, linked to the database, are listed.
- **Object Specific Items Only**: Only the last three components, which are local to this property object, are listed.

**Select Parameters**

In the Global Element Parameters list, choose any of the common parameters of all element types, such as surface, volume, height, thickness or user ID. Shift-click to multi-select.

The Extra Parameters lists those which are specific to the selected element type(s).
List Schemes and Templates

Under **Library Parts' Additional Parameters**, the **Select Additional Parameters** dialog box allows you to select parameters by type and one-by-one.

![Select Additional Parameters dialog box](image)

**List Format Tab Page**

The third tab opens the **List Format** page. The controls in this page allow you to define the overall appearance of the report, and set the logical order of properties and parameters. Choose one of the formatting alternatives: click **Text List** to display raw data, or **Graphic Template** to select a predefined list format template.

![List Format page](image)

These two radio buttons let you toggle between two control windows, described below.
Plain Report

The following page appears when clicking **Text List** button from the List Format tab page.

When you choose this report format, you have only a limited number of controls over the report layout. However, the report will appear in a text window and the list settings fully enable you to logically organize the data in the report.

**Sorting Order**

To change the default order, drag the parameters to their new position in the list.
List Schemes and Templates

Column Headers

Check the **Show Column Headers** checkbox if you want to print column headers in the report. Column headers will bear either the parameter name or a Custom Header. To create a Custom header, check the box next to the Parameter name you want to customize and type the desired header into the text field.

![Column Headers](image)

Listing Preferences

Use the three pop-up menus in the upper part of the tab page to define the listing logic.

At **Elements**, the **Each Item in Separate Row** option creates an item by item list even for identical elements, while **Group and Count Identical** groups and counts up identical items as well as their parameters. *For the difference, see the following reports:*

![Listing Preferences](image)

At **Components**, the **Unfold Components** option lists the parameters of the components. **Quantity Only** will display quantities without units.

At **Descriptors**, the **Unfold Descriptors** will list all the Parameters, Keys and Codes of the Descriptors. **Short Text only** displays only the first line of the descriptor in the report.

*Note:* Text lists can be saved in plain text, tabbed text or HTML format. Text lists will only list the short text of Descriptors.
Graphic Template

This page appears when you click the Graphic Template radio button on top of the List Format tab page.

With a Graphic Template, you can either select a predefined list template from your Library, or use an embedded template layout (or a copy of it).

List layout templates offer sophisticated ready-to-present report formats incorporating both text and graphic elements.

Reports formatted using templates appear in a non-editable project windows. The contents of the windows can be copied to the other project window, including the floor plan views, or saved in ARCHICAD Project, RTF and PlotMaker layout format.

Click the Choose Template button to browse the library for list templates. Select the desired template file in the Open dialog box. Default templates can be found in the List Templates folder of the ARCHICAD Library.

If you use independent templates, ARCHICAD refers to the actual template file for the settings. If you check the Include in List Scheme checkbox, the template file will be archived in the listset.txt file (see above). When the box is checked, the template name appears in italic.

Data Order and Parameter Options

See the Text List section above on how to rearrange the order of data columns and customize columns headers.

If the list of parameters includes Components or Descriptors, use the checkboxes to define additional list items.

Note: Changing data order can result in inconsistent list content if the template contains fixed column headers.
Parameter Listing

Element List template files can include instructions to list element parameters separately and/or add up parameter values in the report. Define your preference for each parameter using the appropriate checkbox:

- **List on separate level**: List parameter types for each element
- **Use for Grouping/Total**: add up parameter values in the report
Component Lists

When selecting a Component List type scheme, the Setup List Schemes dialog box changes accordingly, to display controls available for that list type. Many of the controls are similar to those used for Element Lists. See relevant sections above.

Components Tab Page

In the Keys list on top of the tab page, select the keys to filter the components and descriptors to be listed, or check All box to enable all components and descriptors.

Properties & Parameters Tab Page

The Master Property Controls and Element Parameter checklists work just as they do for Element Lists. (See relevant sections above.)

The Optional Components Data buttons determine which parts of the component will be listed (the name and the quantity always appear).
List Schemes and Templates

The **Fragments** buttons represent the four possible fragments of the Key Code string that are separated by dots. In case of a Key Code of 004.003.002.001, Fragment 3 will return the string '002', as this is the 3rd fragment of the Key Code.

**Zone Lists**

For a Zone List, the **Set Up List Schemes** dialog box changes accordingly. Many of the controls are similar to those used for Element Lists. *See relevant sections above.*

**Zones Tab Page**

The first tab on top of the **Setup List Schemes** dialog box opens the Zones tab page.

Check individual boxes to filter the list by Zone categories; or check All to use all categories.
You can further filter zones using the checkboxes and options under **Zone Number Field** at the upper right of the tab page.

- **Skip if it is empty**: Omits zones without a number
- **Skip Zones with an empty ID field**: Omits zones without ID numbers

**Properties & Parameters Tab Page**

Use the checkboxes to filter the list by Zone parameters. Shift-click to multi-select.

![Diagram](image)

The **Enable Listing of Related Elements** buttons define which element types in the listed zones should be included. Selecting any of these activates the Related Elements tab page (see below).

![Diagram](image)

The **Reduce Wall Quantities** field and the **Linked Property Objects** pop-up work as they do for Element List Schemes *(see above)*.

**Related Elements Tab Page**

This tab page, available only for Zone List Schemes, is active if you previously selected any Related Elements on the Properties and Parameters tab page (see above).
Zone listing is not restricted to the geometry of zones. It also involves the construction elements contained in zones, specifically the surrounding walls, columns, freestanding walls, doors, windows and other objects within Zone spaces.

The controls of the Related Elements page allow you to customize the settings by which the elements associated with a zone or multiple zones are calculated in the zone report. The element types to be considered in calculations are selected in the Properties & Parameters tab page.

The filters of the Related Elements tab page are identical to those of the Properties & Parameters tab page of Element type lists.
Using the Format Wizard/Format Assistant

In the Setup List Schemes dialog box, make the List Format tab active and make sure that the Graphic Template option is chosen. Select a list scheme from the left-hand tree structure, then click the Start Format Wizard (Windows) or Start Format Assistant (Mac) button. This opens a complex dialog box that allows you to rename, delete, duplicate and customize templates.

**Note:** The Wizard/Assistant does not work on external template files, only with embedded layout sections that are stored in binary format, in the program itself, in an ARCHICAD project (.pln, .pla) file, or in the Preferences file.

When you quit the Wizard and return to the Setup List Schemes dialog box, you will notice that the name of the previously created Layout is shown in the Template field, and the include in List Scheme checkbox is enabled. This means that a reference to this layout will be stored in the List Scheme file in the library, but the Layout itself will be saved within the project (.pln, .pla) or in the Preferences file. If you disable the checkbox, the Layout can be saved as an external template text file in the library, but in this case it will no longer be available from within the Wizard.

**Note: New & Reset** deletes all custom Layouts; only factory default Layouts will be available.

See Templates.
Using the Format Wizard/Format Assistant

Format Wizard: Layout Tab Page

The Format Assistant/Wizard dialog box opens with the Layout tab page by default. Select a Graphic Template to edit from the Layout Names list at the left-hand side of the tab page.

- In the list, factory default and locked templates appear in gray. Default templates are wired into the ARCHICAD resource code and cannot be edited; only the details can be viewed in the Format Assistant/Wizard.
- Editable layouts appear in black print and can be customized individually. All existing layouts can be duplicated, including default and locked ones. The copies are freely editable.

Duplicate, rename and delete selected layouts using the corresponding buttons below the Layout Names list at the bottom left of the Layout tab page.

   Note: To edit the template of a locked list scheme, first unlock it in the Setup List Schemes dialog.

Layout Type

Define the layout type of the selected graphic template from the Layout Type pop-up list page.

- To order pages vertically, choose Single Column.
- To organize pages in a grid system, choose Tiled.
Layout Details

Click **Details** to define individual settings for either option (*Single Column* or *Tiled*).

For a **Single Column** list:
- Define the **Line Gap** between two consecutive list items
- Choose the **Layout Scale** to be used when pasting the list into ARCHICAD views
  
  **Note:** The **Auto** option will use the current scale of the Floor Plan.

You can type any remark in the **Comment** field. The comment appears in the Info field of the **Format Assistant/Wizard**.

For a **Tiled** list:
- Use the **Grid** fields to define the number of horizontal and vertical cells, then define the gaps between them in both directions.
- Use the **Cell Sequence** buttons to organize the direction that the cells should follow each other.
Using the Format Wizard/Format Assistant

Edit Page Item

Clicking any of the **Header**, **Footer** or **Background** buttons opens the **Edit Page Item** dialog box where you can edit these settings. It is possible to place a Header and/or Footer on each page or only on the first page. The first page Header and/or Footer can be different from the rest.

Choose the Page Item you wish to modify from the **Edit** pop-up list at the upper left of the dialog box. Predefined formats are available from the **Record Type** pop-up.

Define the Page Item size by typing the desired values in the **Total Width** and **Total Height** fields. Organize the selected Page Item into Fields using the **Rows** and **Columns** fields.

Edit the default text type of the selected page item in the **Default Text Format** dialog box. Use the **Insert text** pop-up to define how the text will be cropped if it does not fit in the cell.
Click Picture to import a bitmap image into the layout of the edited page item. The bitmaps can be external image files from any of the active Libraries, ARCHICAD object symbol drawings generated by Property Objects, or Preview Pictures of ARCHICAD Library Parts in the active Libraries.

Use these controls in the Edit Page Item dialog box to further define the item (e.g. header, footer).

- Use the Field to Edit counters to define which field you wish to modify. The first counter is for the column, the second is for the row.
- Define the size and position of the selected field using the Width, Height and Offset fields.
- To set a non-default text type for the field, click the Text Format button.
• Click the **Borders** button to set Field borders.

Define the contents of **Text Fields**: Choose an item from the pop-up and click the **Insert >>** button. Click the Insert pop-up below to add globally defined data.
Format Wizard: Content Tab Page

Use the Content tab page of the Format Assistant/Wizard to define how to display the parameters in the list.

The Parameters list here is the same as those in the Properties & Parameters tab page of the Setup List Schemes dialog box.
Select the Parameters you want to use to generate Records. The Parameters are listed according to Record type, of which there are three:

- Records to display one by one
- Calculate Totals/Subtotals by...
- Display headlines by...
Check the Parameter boxes to make the selection.
Using the Format Wizard/Format Assistant

Group a selection of checked parameters by clicking the **Group selected parameters** button to the right of the Parameters list field.

![Image of Format Wizard/Format Assistant]

The result is identical with the Group & Count function of Text Lists. Choose the desired option from the **Pagebreak** pop-up to properly organize records on pages.

**Format Wizard: Fields Tab Page**

The Fields tab page is very similar to the **Edit Page Item** dialog box described above. See **Edit Page Item**.

![Image of Fields tab page]

The Parameters selected in the Content tab page appear in the **Parameter & Record** pop-up list.
You can select a predefined Record type for all parameters or you can edit existing ones. Predefined types are available from the Record Type pop-up. When editing predefined Record types, the pop-up will switch to Custom.

See also Step By Step Examples.
SQL in ARCHICAD

SQL is short for Structured Query Language and is the most popular computer language used with databases. It can run queries on databases and get the results in a structured way.

Since an ARCHICAD project is basically a database of building elements (Walls, Slabs, Roofs, Shells, Objects etc.), it is possible using SQL to obtain data about placed elements in a project and display them in table form. By default, the SQL menu items are not enabled in any of the Work Environment Profiles as these are quite advanced features. To enable them, add the following commands to your work environment:

- Execute SQL query
- Show Data Structure

Note: Find these commands using the Options > Work Environment > Menus tab page, and search the Calculation category after listing the menu items as “All commands by theme”.

Select Execute Query to open the SQL Query Window, where you can enter your SQL commands to create lists.

SQL commands work on either selected elements or the whole ARCHICAD Project database. That means if you just started a new Project and no elements are placed yet, any SQL command will give no results.

The way it works is you type SQL commands in the SQL Query Window and the SQL Engine will create an XML file that contains the results and will display it in a browser window.
The ARCHICAD Project database in SQL can be queried in tables. These contain information about elements, parameters, attributes within the Project. For example, the WALLS table contains all the columns (parameters, values connected to Walls) that can be listed for each Wall element.

By selecting the **Show Data Structure** command, your browser window will display an XML file listing all Tables that can be used for queries with the SQL engine.

One of the most used commands of the SQL language is the **SELECT** command. With it you can specify items to be listed. The syntax to be followed in this:

**SELECT <parameters> FROM <table>**

In the **<parameters>** field you can place names of parameters available from the referenced table. If you use the * character, all parameters will be listed. If you want several parameters listed, you can separate them by commas.

The **<table>** field contains the name of the table from which the SQL commands will collect data.
The above `SELECT * FROM WALLS` command takes all parameters available in the `WALLS` table and lists them. The example below lists the User ID, Length, Height and Thickness as the desired parameters, separated with commas.

![Query and Result]

The next SQL command modifier is `WHERE`. With this you can set conditions, thereby effectively limiting which items will be listed. The following code, `SELECT ID, LENGTH, HEIGHT, THICKNESS FROM WALLS WHERE HEIGHT='2.700'` will list only those Walls of the Project that are 2.7 meters in height (numbers in GRAPHISOFT® commands are always metric).

![Query and Result]

There is a special feature in ARCHICAD database which is not part of regular SQL. This is the fact that certain parameters of certain tables are tables themselves. For example, the `Parameters` column of the `OBJECTS` table is a table itself. IF you enter the following code:

```
SELECT USERID, LIBRARY_PART_NAME, PARAMETERS FROM OBJECTS WHERE LIBRARY_PART_NAME='Armchair 01'
```

You will see this result:

The result contains the User ID, Library part Name and Parameters of the **Armchair 01.gsm** object. As you can see, you do not need to use file extensions when referring to Library Part Names in SQL commands. The Parameters column contains a table containing the **PARAMETERS** table with its own columns.

There is a command in GRAPHISOFT SQL to obtain only this table or columns thereof. It is called the **FLAT** command and its syntax is the following:

```
FLAT (<table>, <parameter>) AS <name>
```

In the `<table>` and `<parameter>` field write the name of the parameter and the table you want to be displayed on its own. In the `<name>` field give a new name to this table so you can refer to it.

Here is an example for listing all parameters of the **Armchair 01.gsm** object. The **PARAMETERS** table of the **OBJECTS** table is named **XX**. You can refer to these embedded parameters as **XX.PARAMETERS.<parameter>**, where **XX.PARAMETERS** is the Object parameter table. The screen capture below shows the result of this SQL Query:
Let us see a simple example. With one of the basic Zones listing schemes, we can create the following list of the rooms of a flat in a residential building. All zones belonging to the same flat have the same User ID: 'A1-03'.

The SQL commands to achieve a similar result are the following. With the WHERE part, we can list only Zones belonging to flat 'A1-03':

And the result can be seen below:
The SQL language has many more commands and opportunities than what is described here. You can find detailed information on it on the Internet. A good place to start may be the following web site: [http://www.sql.org/](http://www.sql.org/)

Documentation is available for GRAPHISOFT SQL. It is included in the GRAPHISOFT ODBC (Open Database Connectivity) documentation which can be downloaded from the Documentation section of the GRAPHISOFT Developer Center at the following web page: [http://www.graphisoft.com/support/developer/](http://www.graphisoft.com/support/developer/)

There is also an ODBC driver available for download. It enables users of database applications to connect to ARCHICAD Project databases (*.PLN files for example) and extract data from them. This can be downloaded from the Download section of the GRAPHISOFT Developer Center on GRAPHISOFT's home page.
Step By Step Examples

A: Calculation Examples

Example 1: Zones with all included object types summarized (subtotal by zones)
1. Open the Set up List Schemes the dialog box.
2. Duplicate one of the Zone list schemes and name it, e.g., “Objects by Zones”.
3. In the first tab page (Zones), be sure to set filters appropriately: if you want to list all zones, check all stories, all zone categories, etc.
4. In the second tab page (Properties & Parameters):
   • set None in the Components, Descriptors and Library Part’s Additional Parameters pop-up menus;
   • enable objects (click the chair icon) in the Enable Listing of Related Elements box;
   • set All Elements in the Linked Property Objects pop-up menu;
   • check Zone Name and Zone Number in the Zone Parameters list.
5. In the third tab page (Related Elements):
   • Set None in the Components, Descriptors and Library Part’s Additional Parameters pop-up menus;
• Check Library Part Name in the **Global Element Parameter** list.

![Image of Global Element Parameter list]

6. In the fourth tab page (List Format):
   - Select **Text List**;
   - Set Group & Count Identical in the **Elements** pop-up menu; be make sure that the following parameter list is at the bottom:

![Image of Text List settings]

7. Click **OK** and choose the saved Object by Zones list scheme in **Zone Lists**. You will get a list something like this:

![Image of Zone Lists example]

**Note:** The example provided is a simplified representation for illustrative purposes. In practice, the list might include more detailed attributes depending on the project requirements.
Example 2: Grand total of object types for the entire project

1. Open Set up List Schemes.
2. Duplicate one of the Element list schemes and name it, e.g., “Objects total”.
3. In the first tab page (Elements), be sure to set filters appropriately, i.e., check Objects (chair icon) under “by Types”, check all stories, etc.
4. In the second tab page (Properties & Parameters):
   - set None in the Components, Descriptors and Library Part’s Additional Parameters pop-up menus;
   - check Library Part Name in the Global Element Parameter list.
5. In the third tab-page (List Format):
   - select Text List;
   - set Group & Count Identical in the Elements pop-up menu;
6. Click OK and choose the Objects total list scheme in Element Lists. You will get a list showing the grand total for each object type:
Example 3: Zones with all included object types summarized (subtotal by zones) and the total number of each object type (grand total)

This example describes a complete listing environment that produces the result of the previous two list schemes within one list

**Phase 1: Create the “Object Counter” Property Object**

1. Use the New Properties command to open a blank Library Part Window.
2. Click Properties to open the Property Script window.
3. Copy the following two lines into the Property script:
   
   ```
   dummy = REQUEST ("Name_of_Listed", ",", name)
   COMPONENT name, 1, ",", 1, name
   ```
   
   See the “GDL Reference Guide” in ARCHICAD Help.
4. Save the Property Object as, e.g., “Object Counter”.

   **Note:** This object will generate a separate column for the Quantity (number) of each object type (name)

**Phase 2: Link “Object Counter” to the objects**

**Alternative 1: through individual link**

1. Select all objects to be included in the list.
2. Open the Object Settings dialog box.
3. Go to the Listing Panel.

   **Note:** This panel is not visible by default. To enable it in any construction element’s settings, go to Options > Work Environment > Tool Settings Dialog Boxes.
4. If checked, uncheck the Link Property Objects By Criteria box, and check the Individually box below.
5. The Link Property Objects dialog box opens.
6. Select “Object Counter” in the list and click Link (make sure that the “Object Counter” is under the checkbox as you return to the Object Settings dialog box).

7. Click OK to establish the link.

   **Note:** Any Objects placed afterwards will have to be linked individually.

**Alternative 2: through dynamic link by criteria**

1. Use the **Link Properties to Criteria** command.

2. Select a Database Set in the **Show Links in** pop-up menu.

3. Click **New Link**, then click **Edit Criteria**, the **Criteria Selector** opens up.

4. Set the **Find Elements** pop-up menu to **Of Type>>**, and select Object (chair icon) in the pop-up palette on the right.

5. Click **Apply** and return to the **Link Property Objects to Criteria** dialog box.

6. Close the dialog box and save the criteria when prompted.

7. Select all objects to be included in the list.

8. Open the **Object Settings** dialog box. Go to the Listing Panel.

   **Note:** This panel is not visible by default. To enable it in any construction element’s settings, go to **Options > Work Environment > Tool Settings Dialog Boxes**.

9. If checked, uncheck the **Individually** box and check the **Link Property Objects by Criteria** box.
Note: If you have other existing links for objects in the list, they may be in conflict with these criteria for a particular object. Additional links may be valid, or more specific links can be applied instead of this link.

Phase 3: Setting up the List Scheme

1. Follow steps 1 to 6 from Example 1 or duplicate the existing “Objects by Zones” list scheme and name it, e.g., “Objects by Zones + Total”.
2. In the third (Related Elements) tab page:
   • set Object Specific Items Only in the Components pop-up menu.
   • be sure to check All above the Keys list.
3. In the fourth (List Format) tab page:
   • be sure that the following parameter list is at the bottom:

4. Click OK and choose the previously saved List Scheme from Zone Lists.

B: Graphic Template Setup Example

1. Choose the New Properties command. Save the Property Object to the Property Data folder in your library. Name it for example “drawing”.
2. Create the new parameters X and Y.

3. In the Properties script window, type “DRAWING”.

4. In the 2D script window, type:
   
   DRAWING3 7, 270, 2
   ADD2 x,y
   DRAWING2

   See the “GDL Reference Guide” in ARCHICAD Help.

5. Save the Property Object.

6. Select objects on the Floor Plan and assign this Property Object to them. In the Object Settings dialog box, on the Listing Panel, uncheck the by Criteria checkbox and check the Individually checkbox.

   Note: The Listing Panel is not visible by default. To enable it in any construction element’s settings, go to Options > Work Environment > Tool Settings Dialog Boxes.

7. Then select the Property Object you have just created (drawing).
8. Open the Set up List Schemes dialog box. Select the General Element List scheme and duplicate it (US users: select Element List Set and duplicate it). Name it “My Object Inventory”.

9. On the Elements tab page, choose Objects as the only element type to be included in the list.

10. On the Properties and Parameters tab page, select None in the Components and Descriptors pop-up lists and check the following parameters on the parameter list:

- User ID
- Thickness/Size
- Height
- Library Part name
- Story Name/Viewpoint Name
11. On the List Format tab page, choose Graphic Template. Then change the order of the parameters as shown:

12. Click the Start Format Wizard/Assistant button.
13. In the appearing window, select the General Element List layout.
14. Click the Duplicate button. Name your new list layout: “#My Object Inventory”.
15. Click the **Header** button. Select the Empty Header (landscape) Record Type.

![Image of Edit Page Item dialog for Header]

16. Select **Footer** from the **Edit** pop-up menu, and then select the Empty Footer (landscape) Record type.

![Image of Edit Page Item dialog for Footer]

17. Select **Background** from the **Edit** pop-up menu, and enter 260 mm for the total width and 180 mm for the total height. Enter the same numbers for the width and height fields below.

![Image of Edit Page Item dialog for Background]
Step By Step Examples

18. Click the **Picture** button and select None in the **Use Picture** pop-up.

![Image of Picture dialog box]

19. Click the **Borders** button to open the **Field Borders** dialog box. Check all boxes to draw borders on each side. Click **OK** to return to the **Edit Page Item** dialog box.

![Image of Field Borders dialog box]

20. Select “Header on the first page” from the **Edit** pop-up menu, and select Empty Header (landscape) from the **Record Type** pop-up list.

21. Select “Footer on the first page” from the **Edit** pop-up menu, and select Empty Footer (landscape) from the **Record Type** pop-up list.

22. Click **OK** to return to the Layout tab page.
23. Click the Preview button. (Some Objects must be placed on the Floor Plan, otherwise the preview will not display anything.) Click Done to close the window.

24. Go to the Content tab page and uncheck all checkboxes under the Records to display one-by-one parameter in the Parameters list.

25. Uncheck all checkboxes under the Display Headlines by... parameter in the Parameters list.

26. Select all the parameters under Calculate Totals/Subtotals by (except for Grand Total) and click the Group Selected Parameters button. The result will be as shown below. The five selected parameters will become hierarchically the members of a new group called Group of totals 01-05.
27. Go to the Fields tab page. In the **Parameter & Record** pop-up you have only one item: Group Of Totals 01-05.

28. Set the total width to 260 mm, and set the total height to 100 mm.

29. Set the number of rows to 10, and the number of columns to 6.

30. Click the **Picture** button to open the Picture dialog box, and select **Property Object 2D Full View** from the pop-up list.

31. Enter 100 mm for the width and 50 mm for the height. Also enter 47.1 mm for the first (horizontal) offset and 40 mm for the second (vertical) offset.

32. Click **OK** to return to the Fields tab page of the **Format Wizard/Assistant**.
33. Proceed as follows: choose Row 1/Column 1, select the first parameter from the right-hand side pop-up (User ID) then select Name from the left-hand side pop-up to be displayed in the field. Repeat these steps with all the parameters in the list.

34. The second row displays the actual values of the parameters. Set the Field to Edit counter to the second row and start inserting the values. Select the parameter in the right-hand side pop-up and then choose Insert/Value from the left side pop-up.
35. The third row displays the number of instances. Set the Field to Edit counter to the third row and enter into the first field: “Number of Instances”. For the second field of the third row select the first parameter at the right-hand side pop-up list and choose Insert/Number of Instances.

36. Click the Preview button to see the preview. (Some objects must be placed on the Floor Plan, otherwise the preview will not display anything.) Click Done to return to the Wizard/Assistant.

37. Set the height of the letters in the Default Text Format dialog box to 4 mm and select centered justification.

38. For each field set the borders to be displayed on the bottom of the field. Click the Borders button and check the Bottom checkbox.

39. The fields of the second line could be offset vertically by 2 mm so that it looks a little tidier. Enter the offset for each field separately. The third line could be offset 5 mm vertically. Enter the offset for each field separately.

40. Click Done to finish.
41. Select **Element Lists > My Object Inventory** to display the list.

<table>
<thead>
<tr>
<th>User ID</th>
<th>Library Part Name</th>
<th>Story Name / Viewpoint Name</th>
<th>Thickness/Size</th>
<th>Height</th>
</tr>
</thead>
<tbody>
<tr>
<td>FU-066</td>
<td>Chair Layout 18</td>
<td>Ground Floor</td>
<td>3.40</td>
<td>0.85</td>
</tr>
</tbody>
</table>
Index

A
Assignment
~ of Properties data 38
direct individual ~ to Properties data 38

B
Bills of Materials
creating ~ 12

C
Calculation Commands 7
Component and Descriptor Links to Databases 33
Component List Schemes 59
Component Lists 7
~ customization 59
definition 12
Components
~ in Element Lists 52
Database ~ 24
definition 16
Object-Specific ~ 30
Components and Descriptors
~ editing 30
Criteria
~ assigning Properties by ~ 38
Criteria Selector
~ dialog box 34, 36

D
Database
~ & List Schemes 43
~ Descriptors 26
default ~ 14
Link to ~ Item 33
Descriptors
~ in Element Lists 52
definition 17
Object-Specific ~ 31

E
Edit Properties
~ command 28
Editing Criteria 36
Element List Schemes
~ Complexity 56
List Format 54
Properties & Parameters 51
Element Lists 7
definition 10, 11

F
Fields
~ in Graphic Templates 43
Filter by Element
~ List Schemes 47
Filter by Label & ID
~ List Schemes 48
Filter by Layer
~ List Schemes 48
Filter by Property Objects
~ List Schemes 49
Filter by Story
~ List Schemes 49
Format Assistant 9
~ list layout formatting 63
Format Wizard 9

G
Graphic Reports 8
Graphic Templates
~ for Element Lists 57

H
Header
~ on Element Lists 56

I
Inventories
creating ~ 10
Index

K
Keys
  ~ in Element Lists 51
    definition 14
    editing ~ 21

L
Last Selection’s Properties...
  ~ command 40
Layout
  ~ in Graphic Templates 64
Link Properties to Criteria...
  ~ command 34
List Formats
  Graphic Reports 57
  plain Element List 55
  Plain Text Reports 8
List Schemes
  creating new ~ 46
    definition 8
  deleting ~ 46
  locking ~ 46
  organization of ~ 45
  renaming ~ 46
  selecting a ~ 45
Listing Commands 7
LISTSET.TXT
  ~ database file 46

N
New Properties
  ~ command 28

O
Output Reports 8

P
Price Lists
  creating ~ 12
Properties
  creating new ~ 27
    editing ~ 28
Property Objects
  definition 27
    linking ~ 27

Q
Quantity Takeoffs
  creating ~ 12

R
Records
  ~ in Graphic Templates 43
Reduce Wall Quantities 48
Room Schedules
  creating ~ 13

S
Setup List Schemes
  ~ command 44
Single Column
  ~ layouts 65
Sorting Order
  ~ for Element List parameters 55
SQL commands 72
SQL in ARCHICAD 72
SQL language 77
SQL Query Window 72
Structured Query Language 72

T
Template
  selecting a graphic ~ 57
Tiled
  ~ layouts 65

U
Units 18
  editing ~ 22

Z
Zone List Schemes 60
Zone Lists 7
  customization 60
  definition 13